Online sketches don’t work

I’m trying to evaluate Charts-kt, but I have encountered some issues.
Online sketches don’t work (I have tried different browsers just to be sure…), but more importantly I can’t even replicate the examples following the guide Creating your first JavaFX chart app series. All the examples use for example newVizContainer but it is an unresolved reference. Maybe because only io.data2viz.charts.core is available to test?
Is there a way to solve it?

Hello Alberto, and thank you for the feedback.

Could you give us some links on “non-working” sketches? Is it in the documentation pages or on

I just checked the documentation pages, and it seemed ok (see the screen recording below).

CleanShot 2021-04-29 at 23.42.39

We’ll look at the tutorial code to see if it’s a breaking change between the latest 1.0.x version and the upcoming 1.1.

The sketches inside the documentation works, but those in the explore section of the site give me some kind of error. For example:


This is the sketches
Fortunately for the second question I have solved. It was my problem, basically because I’m new in the java world and so the javafx stuff. My bad!

1 Like

@alberto.vaccariello The problem with the sketch is weird.

Can you open the dev tools to display the loading of Javascript files?

The client execution environment should load all the libraries, including kotlin.js.

CleanShot 2021-04-30 at 10.10.22@2x

Yes it’s weird but I solved the problem. It was an extension that I must use for smart working that for some reason is blocking the sketches. Disabling it for the site solved the problem.
Sorry if I wasted your time.